tls-crypt-v2 + opnsense = errors detected

Looking for assistance with a cryptostorm connection issue? Post here & we'll help out. Also: if you're not sure where to post, do so here & we'll move things around as needed. Also: for quickest support, email our oddly calm & easygoing support reps at support@cryptostorm.is :)
opns670user
Posts: 2
Joined: Sat Apr 23, 2022 3:08 pm

tls-crypt-v2 + opnsense = errors detected

Post by opns670user » Sat Apr 23, 2022 3:38 pm

The following input errors were detected:
• The field 'TLS Shared Key' does not appear to be valid


i have spent the past few saturday mornings editing the TLS Shared Key area. and all i get is the above.

using ED448 connection :(

https://cryptostorm.is/blog/tlscryptv2
following area For everyone else

<tls-crypt-v2>
new data generated from the site listed
</tls-crypt-v2>

try to save and get the error at the top of the post.

does anyone have this working on:
OPNsense 22.1.6-amd64
FreeBSD 13.0-STABLE
OpenSSL 1.1.1n 15 Mar 2022