Ξ welcome to cryptostorm's member forums ~ you don't have to be a cryptostorm member to post here Ξ
Ξ any OpenVPN configs found on the forum are likely outdated. For the latest, visit here or GitHub Ξ
Ξ If you're looking for tutorials/guides, check out the new https://cryptostorm.is/#section6 Ξ

Can't use Wireguard (Unable to set interface etc etc error)

Looking for assistance with a cryptostorm connection issue? Post here & we'll help out. Also: if you're not sure where to post, do so here & we'll move things around as needed. Also: for quickest support, email our oddly calm & easygoing support reps at support@cryptostorm.is :)

Topic Author
mrmaert
Posts: 2
Joined: Sun Sep 22, 2019 10:08 pm

Can't use Wireguard (Unable to set interface etc etc error)

Post by mrmaert » Sun Sep 22, 2019 10:22 pm

Hi, I recently purchased a token to try the full service with Wireguard(latest version), unfortunately I'm unable to get it work.
I carefully followed the configuration guide but I always get this error:

Unable to set interface addresses, routes, dns, and/or interface settings: runNetsh run - exit status 1


I read the whole log and it's all good and well until this error occur and everything shuts down.
Has someone encountered the same error and knows a way to solve this?


csw1r3
Posts: 2
Joined: Thu Sep 26, 2019 4:11 am

Re: Can't use Wireguard (Unable to set interface etc etc error)

Post by csw1r3 » Thu Sep 26, 2019 4:15 am

Was able to connect successfully on macOS and iOS - so that appears to be working. However, traffic does not seem to be routed anywhere, can't even ping assigned/designated IP or DNS at 10.31.33.7 or .8. Anyone knows what may be causing this and how to fix?


Topic Author
mrmaert
Posts: 2
Joined: Sun Sep 22, 2019 10:08 pm

Re: Can't use Wireguard (Unable to set interface etc etc error)

Post by mrmaert » Thu Sep 26, 2019 11:19 am

csw1r3 wrote:
Thu Sep 26, 2019 4:15 am
Was able to connect successfully on macOS and iOS - so that appears to be working. However, traffic does not seem to be routed anywhere, can't even ping assigned/designated IP or DNS at 10.31.33.7 or .8. Anyone knows what may be causing this and how to fix?
Yes, I contacted support and finally managed to connect wireguard, but no internet access, anything. What's not working now is beyond my knowledge.


mma
Posts: 2
Joined: Tue Oct 01, 2019 8:01 pm

Re: Can't use Wireguard (Unable to set interface etc etc error)

Post by mma » Tue Oct 01, 2019 8:03 pm

Same issue here.
On IOS I'm able to connect to wireguard:
  • [APP] Status update notification timeout for tunnel 'dusseldorf'. Tunnel status is now 'connected'
But I'm not able to route traffic anywhere as well (not even able to ping the CS nameservers)

Is there a solution for this? Idk what else to try..

With Mullvad works without any issues it also works fine when using the Paris node, so I guess there's something specific to Cryptostorm that is causing this?

User avatar

df
Site Admin
Posts: 417
Joined: Thu Jan 01, 1970 5:00 am

Re: Can't use Wireguard (Unable to set interface etc etc error)

Post by df » Wed Oct 02, 2019 11:56 pm

The issue should be resolved now


mma
Posts: 2
Joined: Tue Oct 01, 2019 8:01 pm

Re: Can't use Wireguard (Unable to set interface etc etc error)

Post by mma » Fri Oct 04, 2019 7:43 pm

It's working now! Thanks df!

Post Reply