TAP and Win10 pains

Looking for assistance with a cryptostorm connection issue? Post here & we'll help out. Also: if you're not sure where to post, do so here & we'll move things around as needed. Also: for quickest support, email our oddly calm & easygoing support reps at support@cryptostorm.is :)

TAP and Win10 pains

Post by WhyOhWhyOhWhy » Fri Feb 03, 2017 1:02 am

I'm having problems getting onto Cryptofree with my new Win10 lappy (no token currently, trying to get onto free to buy the token)

I've tried OpenVPN via cmd batch (run as admin), batches that work fine on another 10 laptop and my 7 desktop.

I've tried the latest widget.

I've got a "firmed" (not totally hardened) 10 install, so maybe some part of 10 is busted by me and not dealing with the TAP/TUN properly.
Without doing a fresh install (need to image the current setup first as it's working ok for work right now, just not VPN) I can't check easily.

The OpenVPN and widget readouts both give the same issue:

TEST ROUTES: 0/0 succeeded len=-1 ret=0 a=0 u/d=down
Route: Waiting for TUN/TAP interface to come up...

I've tried all manner of drivers and OpenVPN versions, including the versions running on my other 10 laptop (firmed version, maybe not as firm as this version though) which work.

I've pretty much binned ipv6 here, and run no networking features except the ipv4 in the adapter settings. I've left the default TAP settings as installed though.

Does anyone know of anything else I can check?

The only other thing I can think of is the firewall, it's got just DNS (any IP allowed so that should be ample), and DHCP (also any IP, though I know it just needs my router one?), and Firefox, and the openvpn.exe client.

The openvpn is also set to run as admin, despite me running my cmd batch as admin that runs the openvpn cmd.

The only oddity I had was noting the DNS service (svchost.exe) trying to get through the firewall lots (absolute path instance), despite me having a %root% svchost.exe reference for DNS service already in the firewall.

Making me wonder if there is some issue with admin/user and firewalling for DNS stuff?

Fucking Windows 10!

Windows 7 feels like a beautfully made bolt action rifle, to Windows 10 which is like an elastic band gun made from soggy cardboard!