Ξ welcome to cryptostorm's member forums ~ you don't have to be a cryptostorm member to post here Ξ
Ξ any OpenVPN configs found on the forum are likely outdated. For the latest, visit here or GitHub Ξ
Ξ If you're looking for tutorials/guides, check out the new https://cryptostorm.is/#section6 Ξ

Error: the plugin doesn't support import capability, Ubuntu 16.04 LTS

Looking for assistance with a cryptostorm connection issue? Post here & we'll help out. Also: if you're not sure where to post, do so here & we'll move things around as needed. Also: for quickest support, email our oddly calm & easygoing support reps at support@cryptostorm.is :)

Topic Author
guy
Posts: 1
Joined: Fri Apr 29, 2016 7:26 pm

Error: the plugin doesn't support import capability, Ubuntu 16.04 LTS

Post by guy » Fri Apr 29, 2016 7:42 pm

I'm trying to establish connection in Ubuntu 16.04 LTS using the cryptofree howto Ubuntu tutorial, but I keep getting the following error:
Error: the plugin doesn't support import capability
Image

It's hard to believe that Ubuntu developers left such a glaring bug in an LTS release, but, judging by this AskUbuntu question, it looks so.

How can I proceed to connect to Cryptostorm network on Ubuntu 16.04 LTS?

User avatar

parityboy
Site Admin
Posts: 1253
Joined: Wed Feb 05, 2014 3:47 am

Re: Error: the plugin doesn't support import capability, Ubuntu 16.04 LTS

Post by parityboy » Fri Apr 29, 2016 8:52 pm

@OP

I'm gonna take a guess and say that the VPn plugin is either expecting - or doesn't like the presence of - <remote></remote> tags around the exit node entries in the OpenVPN config files. See if adding/removing them makes a difference.

I might spin up a 16.04 VM over the weekend and take a closer look. :)

User avatar

Fermi
Site Admin
Posts: 202
Joined: Tue Jun 17, 2014 11:42 am

Re: Error: the plugin doesn't support import capability, Ubuntu 16.04 LTS

Post by Fermi » Fri Apr 29, 2016 9:04 pm

Hi,

Next to:

Code: Select all

sudo apt-get install network-manager-openvpn-gnome
did you also :

Code: Select all

sudo apt-get install network-manager-openvpn
followed by:

Code: Select all

service network-manager restart
?

Later I saw this:
You can connect from the command line:

Code: Select all

sudo openvpn --config ~/openvpn/xxx.conf
depending on the path where you have stored the configuration of course.

/fermi


wpaschukat
Posts: 14
Joined: Sun Mar 22, 2015 3:25 am

Re: Error: the plugin doesn't support import capability, Ubuntu 16.04 LTS

Post by wpaschukat » Fri Apr 29, 2016 10:32 pm

Error: the plugin doesn't support import capability
I might be wrong, but just in case you tried to download a single .ovpn from within github - that might not work as it is hmtl.
Download the conf in total from here https://github.com/cryptostorm/cryptost ... master.zip and extract the relevant config.

Tada.

User avatar

Tealc
ForumHelper
Posts: 238
Joined: Tue Jan 28, 2014 12:38 am

Re: Error: the plugin doesn't support import capability, Ubuntu 16.04 LTS

Post by Tealc » Sun May 01, 2016 3:31 am

This is a know issue with 16.04!! And there are currently no workaround! Ubuntu broke the network-manager-openvpn, if you updated from 15.10 with that working you should be fine but you will not be able to import ovpn conf's files.
I found this out the worse way, brand new laptop install with 16.04, put it like the way I wanted, them tried VPN, and manage to import ovpn conf's files by separating the cert's & keys from the conf, it imported fine, but when connecting with would scream some stupid error, I submitted the error and found that many, many others had the same problem.

Still you can use command line, there it works just fine! :-D

https://bugs.launchpad.net/ubuntu/+sour ... er-openvpn -- > The bug is currently HIGH on the list since it's affecting everyone that upgraded to 16.04

Post Reply