Ξ welcome to cryptostorm's member forums ~ you don't have to be a cryptostorm member to post here Ξ
Ξ any OpenVPN configs found on the forum are likely outdated. For the latest, visit here or GitHub Ξ
Ξ If you're looking for tutorials/guides, check out the new https://cryptostorm.is/#section6 Ξ

unable to connect with router or android. widget ok

Looking for assistance with a cryptostorm connection issue? Post here & we'll help out. Also: if you're not sure where to post, do so here & we'll move things around as needed. Also: for quickest support, email our oddly calm & easygoing support reps at support@cryptostorm.is :)

Topic Author
ironleg

unable to connect with router or android. widget ok

Post by ironleg » Sat Oct 03, 2015 6:00 am

I have original Asus firmware for the Asus RT-AC68U router. I am unable to connect with my router or my android tablet. here is the log for my android tablet.
android log.txt
(9.52 KiB) Downloaded 2953 times
My Router just says disconnected. I tried another vpn (express vpn) and it connected OK. My windows widget connects OK. any Ideas to resolve this issue?

User avatar

parityboy
Site Admin
Posts: 1253
Joined: Wed Feb 05, 2014 3:47 am

Re: unable to connect with router or android. widget ok

Post by parityboy » Sat Oct 03, 2015 4:27 pm

@OP

Let's start with the Android tablet.

Which version of the OS are you running?
Which OpenVPN client are you running?
Which server(s) are you trying to connect to?

I'll take a look at the log in the mean time...also have you seen this link?


Topic Author
ironleg

Re: unable to connect with router or android. widget ok

Post by ironleg » Sun Oct 04, 2015 9:43 am

my android tablet is a kindle fire HDX 8.9 latest update, latest version of openvpn for android and uswest and tried uscentral.

User avatar

Tealc
ForumHelper
Posts: 238
Joined: Tue Jan 28, 2014 12:38 am

Re: unable to connect with router or android. widget ok

Post by Tealc » Sun Oct 04, 2015 9:46 pm

I'm finding this really strange:

VpnService routes installed: 0.0.0.0/1, 128.0.0.0/2, 192.0.0.0/9, 192.128.0.0/11, 192.160.0.0/13, 192.168.0.0/24, 192.168.2.0/23, 192.168.4.0/22, 192.168.8.0/21, 192.168.16.0/20, 192.168.32.0/19, 192.168.64.0/18, 192.168.128.0/17, 192.169.0.0/16, 192.170.0.0/15, 192.172.0.0/14, 192.176.0.0/12, 192.192.0.0/10, 193.0.0.0/8, 194.0.0.0/7, 196.0.0.0/6, 200.0.0.0/5, 208.0.0.0/4, 224.0.0.0/3

How many networks do your router run?

What's in that dnsmasq or similar?

User avatar

parityboy
Site Admin
Posts: 1253
Joined: Wed Feb 05, 2014 3:47 am

Re: unable to connect with router or android. widget ok

Post by parityboy » Sun Oct 04, 2015 11:29 pm

@ironleg

That Android OpenVPN you're using: is that the "official" one or Arne Schwab's implementation?


Topic Author
ironleg

Re: unable to connect with router or android. widget ok

Post by ironleg » Mon Oct 05, 2015 1:44 am

I am using the latest version, official openvpn apk Arne Schwab. dnsmasq is a feature of Asus-Merlin firmware, I have changed my firmware to AsusWRT firmware.


Topic Author
ironleg

Re: unable to connect with router or android. widget ok

Post by ironleg » Wed Oct 07, 2015 1:39 pm

I tried my Android phone with the latest version of openvpn for Android from the play store. It says connected but no internet is available. I have tried it on two different routers, a kindle, and Android phone. I like the fact that Cryptostorm is not in the USA but I want a simple install that I can setup. If I can't get it to work then I will have to go elsewhere.

User avatar

parityboy
Site Admin
Posts: 1253
Joined: Wed Feb 05, 2014 3:47 am

Re: unable to connect with router or android. widget ok

Post by parityboy » Wed Oct 07, 2015 10:33 pm

@ironleg

What make is the Android phone and which version of Android is the phone running? I have CryptoStorm running perfectly on a Nexus 4 running 4.2.2, using the Arne Schwab OpenVPN client.

I'm pretty sure I can help get you set up. :)


Topic Author
Ironleg

Re: unable to connect with router or android. widget ok

Post by Ironleg » Fri Oct 09, 2015 9:06 am

Samsung gem 4.2.2 Android
Arne Schwab openvpn for Android latest version.
Kindle fire HDX software version 4.5.5
Technicolor C2000T modem/router from ISP
I have tried cyberghost vpn, express vpn, and cryptostorm vpn. I am able to connect with no issues with express vpn only. I am looking to install cyberghost vpn on one device to cover all my internet connections. I have a Asus RT-AC68U router I would like to put the cryptostorm vpn on.I have tried the Android how to by Tealc. I have added the two buffer size and the resolvers of nu,net,org, and still no connections.


Topic Author
ironleg

Re: unable to connect with router or android. widget ok

Post by ironleg » Sat Oct 10, 2015 12:39 pm

Use Cryptostorm, not cyberghost. Sorry

User avatar

parityboy
Site Admin
Posts: 1253
Joined: Wed Feb 05, 2014 3:47 am

Re: unable to connect with router or android. widget ok

Post by parityboy » Sat Oct 10, 2015 6:26 pm

@ironleg

Try this, this is what I used to connect - I went through these steps on a Nexus 4 running 4.2.2 while writing this post, so I KNOW they work.

1. Download and install the latest version of Arne Schwab's OpenVPN client for Android.
2. Download an Android OpenVPN configuration file from this post (see attached).
3. In the client, tap the "open folder" icon at the top of the screen.
4. Navigate to the folder where the configuration file is saved, tap it then hit "Select".
5. On the next screen tap the floppy disk icon in the bottom right of the screen to save the profile.
6. On the main screen tap the settings icon for the new profile.
7. Fill in the username with your token hash, and the password with a default password. Apparently you can use anything as the password. I use 93b66e7059176bbfa418061c5cba87dd.
8. You can change the profile name to something more meaningful.
9. Hit the back button on your device.
10. Tap the entry for the new profile, and watch the log as it connects.
11. Test the connection by using a browser and navigating to this link.

Handy Tip: Avail yourself of a QRCode reader and generator, they are of enormous help when trying to get long hashes into a username field on a mobile device. :D

Hope this helps. :)
Attachments
cstorm_android_dynamic_1-4.conf
(7.28 KiB) Downloaded 356 times


Topic Author
ironleg

Re: unable to connect with router or android. widget ok

Post by ironleg » Sun Oct 11, 2015 12:30 pm

I followed your instructions,
Here is a copy of my log files from my tablet.

Code: Select all

2015-10-11 01:25:27 Running on KFAPWI (MSM8974) Amazon, Android API 19, version 0.6.35, official build
2015-10-11 01:25:38 Building configuration…
2015-10-11 01:25:41 started Socket Thread
2015-10-11 01:25:41 P:Initializing Google Breakpad!
2015-10-11 01:25:41 Warning: Error redirecting stdout/stderr to --log file: devnull.txt: Read-only file system (errno=30)
2015-10-11 01:25:41 Current Parameter Settings:
2015-10-11 01:25:41 NOTE: --mute triggered...
2015-10-11 01:25:41 956 variation(s) on previous 1 message(s) suppressed by --mute
2015-10-11 01:25:41 OpenVPN 2.4-icsopenvpn [git:icsopenvpn_634-601da8f5c2cb21d4] android-14-armeabi-v7a [SSL (OpenSSL)] [LZO] [SNAPPY] [LZ4] [EPOLL] [MH] [IPv6] built on Aug 11 2015
2015-10-11 01:25:41 library versions: OpenSSL 1.0.1l 15 Jan 2015, LZO 2.09
2015-10-11 01:25:41 MANAGEMENT: Connected to management server at /data/data/de.blinkt.openvpn/cache/mgmtsocket
2015-10-11 01:25:41 MANAGEMENT: CMD 'hold release'
2015-10-11 01:25:41 NOTE: --mute triggered...
2015-10-11 01:25:41 4 variation(s) on previous 1 message(s) suppressed by --mute
2015-10-11 01:25:41 MANAGEMENT: >STATE:1444548341,RESOLVE,,,
2015-10-11 01:25:41 Network Status: CONNECTED  to WIFI "CenturyLink8112"
2015-10-11 01:25:41 NOTE: --mute triggered...
2015-10-11 01:25:45 31 variation(s) on previous 1 message(s) suppressed by --mute
2015-10-11 01:25:45 MANAGEMENT: CMD 'proxy NONE'
2015-10-11 01:25:46 LZO compression initializing
2015-10-11 01:25:46 Control Channel MTU parms [ L:1602 D:1212 EF:38 EB:0 ET:0 EL:3 ]
2015-10-11 01:25:46 NOTE: --mute triggered...
2015-10-11 01:25:46 1 variation(s) on previous 1 message(s) suppressed by --mute
2015-10-11 01:25:46 Local Options String (VER=V4): 'V4,dev-type tun,link-mtu 1602,tun-mtu 1500,proto UDPv4,comp-lzo,cipher AES-256-CBC,auth SHA512,keysize 256,key-method 2,tls-client'
2015-10-11 01:25:46 NOTE: --mute triggered...
2015-10-11 01:25:46 1 variation(s) on previous 1 message(s) suppressed by --mute
2015-10-11 01:25:46 TCP/UDP: Preserving recently used remote address: [AF_INET]109.71.42.164:443
2015-10-11 01:25:46 Socket Buffers: R=[163840->131072] S=[163840->131072]
2015-10-11 01:25:46 MANAGEMENT: CMD 'needok 'PROTECTFD' ok'
2015-10-11 01:25:46 UDP link local: (not bound)
2015-10-11 01:25:46 UDP link remote: [AF_INET]109.71.42.164:443
2015-10-11 01:25:46 MANAGEMENT: >STATE:1444548346,WAIT,,,
2015-10-11 01:25:46 NOTE: --mute triggered...
2015-10-11 01:25:46 1 variation(s) on previous 1 message(s) suppressed by --mute
2015-10-11 01:25:46 TLS: Initial packet from [AF_INET]109.71.42.164:443, sid=84014b76 e00e5021
2015-10-11 01:25:46 WARNING: this configuration may cache passwords in memory -- use the auth-nocache option to prevent this
2015-10-11 01:25:47 VERIFY OK: depth=1, C=CA, ST=QC, L=Montreal, O=Katana Holdings Limite /  cryptostorm_darknet, OU=Tech Ops, CN=cryptostorm_is, emailAddress=certadmin@cryptostorm.is
2015-10-11 01:25:47 NOTE: --mute triggered...
2015-10-11 01:25:49 2 variation(s) on previous 1 message(s) suppressed by --mute
2015-10-11 01:25:49 WARNING: 'link-mtu' is used inconsistently, local='link-mtu 1602', remote='link-mtu 1606'
2015-10-11 01:25:49 WARNING: 'mtu-dynamic' is present in remote config but missing in local config, remote='mtu-dynamic'
2015-10-11 01:25:49 Data Channel Encrypt: Cipher 'AES-256-CBC' initialized with 256 bit key
2015-10-11 01:25:49 NOTE: --mute triggered...
2015-10-11 01:25:49 4 variation(s) on previous 1 message(s) suppressed by --mute
2015-10-11 01:25:49 [server] Peer Connection Initiated with [AF_INET]109.71.42.164:443
2015-10-11 01:25:50 MANAGEMENT: >STATE:1444548350,GET_CONFIG,,,
2015-10-11 01:25:50 SENT CONTROL [server]: 'PUSH_REQUEST' (status=1)
2015-10-11 01:25:50 NOTE: --mute triggered...
2015-10-11 01:25:50 7 variation(s) on previous 1 message(s) suppressed by --mute
2015-10-11 01:25:50 ROUTE_GATEWAY 127.100.103.119/255.0.0.0 IFACE=lo HWADDR=00:00:00:00:00:00
2015-10-11 01:25:50 do_ifconfig, tt->ipv6=0, tt->did_ifconfig_ipv6_setup=0
2015-10-11 01:25:50 MANAGEMENT: >STATE:1444548350,ASSIGN_IP,,10.44.46.194,
2015-10-11 01:25:50 MANAGEMENT: CMD 'needok 'IFCONFIG' ok'
2015-10-11 01:25:50 NOTE: --mute triggered...
2015-10-11 01:25:50 Opening tun interface:
2015-10-11 01:25:50 Ignoring multicast route: 224.0.0.0/3
2015-10-11 01:25:50 Local IPv4: 10.44.46.194/16 IPv6: null MTU: 1500
2015-10-11 01:25:50 DNS Server: 109.71.42.228, Domain: null
2015-10-11 01:25:50 Routes: 0.0.0.0/0 
2015-10-11 01:25:50 Routes excluded: 192.168.0.12/24 
2015-10-11 01:25:51 VpnService routes installed: 0.0.0.0/1, 128.0.0.0/2, 192.0.0.0/9, 192.128.0.0/11, 192.160.0.0/13, 192.168.1.0/24, 192.168.2.0/23, 192.168.4.0/22, 192.168.8.0/21, 192.168.16.0/20, 192.168.32.0/19, 192.168.64.0/18, 192.168.128.0/17, 192.169.0.0/16, 192.170.0.0/15, 192.172.0.0/14, 192.176.0.0/12, 192.192.0.0/10, 193.0.0.0/8, 194.0.0.0/7, 196.0.0.0/6, 200.0.0.0/5, 208.0.0.0/4, 224.0.0.0/3 
2015-10-11 01:25:51 4 variation(s) on previous 1 message(s) suppressed by --mute
2015-10-11 01:25:51 Initialization Sequence Completed
2015-10-11 01:25:51 MANAGEMENT: >STATE:1444548351,CONNECTED,SUCCESS,10.44.46.194,109.71.42.164
When I tried to go to a website I would get page cannot be displayed error.
 ! Message from: parityboy
Edited to improve formatting.

User avatar

parityboy
Site Admin
Posts: 1253
Joined: Wed Feb 05, 2014 3:47 am

Re: unable to connect with router or android. widget ok

Post by parityboy » Sun Oct 11, 2015 8:26 pm

@ironleg

First and foremost, did you try out the steps on the Android device running 4.2.2?

Secondly, there are a few differences between your logs and mine, but the most prominent - to my eyes, anyway - is this:

Yours:

Code: Select all

2015-10-11 01:25:51 VpnService routes installed: 0.0.0.0/1, 128.0.0.0/2, 192.0.0.0/9, 192.128.0.0/11, 192.160.0.0/13, 192.168.1.0/24, 192.168.2.0/23, 192.168.4.0/22, 192.168.8.0/21, 192.168.16.0/20, 192.168.32.0/19, 192.168.64.0/18, 192.168.128.0/17, 192.169.0.0/16, 192.170.0.0/15, 192.172.0.0/14, 192.176.0.0/12, 192.192.0.0/10, 193.0.0.0/8, 194.0.0.0/7, 196.0.0.0/6, 200.0.0.0/5, 208.0.0.0/4, 224.0.0.0/3
Mine:

Code: Select all

2015-10-11 16:08:47 VpnService routes installed: 0.0.0.0/0
What caught my eye is "VpnService routes installed: 0.0.0.0/1", which to me doesn't look right. Since your device is running API 19 (4.4.2) I'll spin up a VM, do some testing and report back. In the meantime, can you post the logs from your router?

Cheers. :)

EDIT:
While I'm doing that, could you also download NetStat onto your Kindle and take a screenshot? I need to know what your routing table looks like while the VPN tunnel is active.

Cheers. :)


Topic Author
ironleg

Re: unable to connect with router or android. widget ok

Post by ironleg » Mon Oct 12, 2015 5:36 am

I think I figured it out. My modem/router had the firewall enabled by default so I turned it off. I am able to connect with my kindle. Will try my Android phone and router.

User avatar

parityboy
Site Admin
Posts: 1253
Joined: Wed Feb 05, 2014 3:47 am

Re: unable to connect with router or android. widget ok

Post by parityboy » Mon Oct 12, 2015 5:09 pm

@ironleg

You're saying your router blocked outgoing connections to port 443? A rather odd configuration...

Post Reply