Switzerland node - error connecting to some sites

Looking for assistance with a cryptostorm connection issue? Post here & we'll help out. Also: if you're not sure where to post, do so here & we'll move things around as needed. Also: for quickest support, email our oddly calm & easygoing support reps at support@cryptostorm.is :)
Moonlight

Switzerland node - error connecting to some sites

Post by Moonlight » Thu Mar 25, 2021 6:40 am

win 10 x64 - os build 19042.870

cs 3.45.0.43

Since 24/03, getting these error messages when connecting to some sites through the Switzerland node (no issues at all with Dusseldorf and France), e.g. :

(1)

Microsoft Edge

Hmmm … can't reach this page www.cryptostorm.ch’s server IP address could not be found.
Try:

Checking the connection
Checking the proxy, firewall, and DNS settings.
Running Windows Network Diagnostics

ERR_NAME_NOT_RESOLVED

(2)

Opera

This site can’t be reached
uptime.statuscake.com’s server IP address could not be found.

Try:
Checking the proxy, firewall, and DNS configuration
Running Windows Network Diagnostics
Changing DNS over HTTPS settings
DNS_PROBE_FINISHED_BAD_CONFIG
Check your DNS settings.
Contact your network administrator if you're not sure what this means.

Check your DNS over HTTPS settings
Go to Opera > Preferences… > System > Use DNS-over-HTTPS instead of the system’s DNS settings and check your DNS-over-HTTPS provider.

Thank you.

User avatar
df
Site Admin
Posts: 472
Joined: Thu Jan 01, 1970 5:00 am

Re: Switzerland node - error connecting to some sites

Post by df » Fri Mar 26, 2021 12:05 am

That server's been under a heavy DNS-based DDoS attack for a couple of days now that's causing the upstream to block DNS traffic. I just temporarily disabled the public DNS server there on 81.17.31.34 so now DNS is only reachable on the 10.31.33.7 and 10.31.33.8 IPs that can only be accessed while on the VPN.
Now we just need to wait for the upstream to unblock us. The VPN server is still reachable, but DNS won't work until they unblock us.

EDIT:
For now, I'll just forward all DNS on the Switzerland server to the Austrian server so people connecting to Switzerland won't get anymore DNS errors. I'll switch it back to 81.17.31.34 whenever it's unblocked.

Moonlight

Re: Switzerland node - error connecting to some sites

Post by Moonlight » Thu Apr 01, 2021 2:06 am

Since 30/3 widget indicates that it is connected but sites visited are timing out, e.g.

The connection has timed out

The server at cryptostorm.ch is taking too long to respond.

The site could be temporarily unavailable or too busy. Try again in a few moments.
If you are unable to load any pages, check your computer’s network connection.
If your computer or network is protected by a firewall or proxy, make sure that Opera is permitted to access the Web.

Selected extracts from widget:

WARNING: You have specified redirect-gateway and redirect-private at the same time (or the same option multiple times). This is not well supported and may lead to unexpected results

ROUTE: route addition failed using CreateIpForwardEntry: The object already exists. [status=5010 if_index=14]
Route addition via IPAPI failed [adaptive]
Route addition fallback to route.exe
env_block: add PATH=C:\WINDOWS\System32;C:\WINDOWS;C:\WINDOWS\System32\Wbem
C:\WINDOWS\system32\route.exe ADD 0.0.0.0 MASK 128.0.0.0 10.xx.x.x
ROUTE: route addition failed using CreateIpForwardEntry: The object already exists. [status=5010 if_index=19]
Route addition via IPAPI failed [adaptive]
Route addition fallback to route.exe
env_block: add PATH=C:\WINDOWS\System32;C:\WINDOWS;C:\WINDOWS\System32\Wbem
C:\WINDOWS\system32\route.exe ADD 128.0.0.0 MASK 128.0.0.0 10.xx.x.x
ROUTE: route addition failed using CreateIpForwardEntry: The object already exists. [status=5010 if_index=19]
Route addition via IPAPI failed [adaptive]
Route addition fallback to route.exe
env_block: add PATH=C:\WINDOWS\System32;C:\WINDOWS;C:\WINDOWS\System32\Wbem
Initialization Sequence Completed
Connected
2021-04-01 06:29:01 Start ipconfig commands for register-dns...
2021-04-01 06:29:01 C:\WINDOWS\system32\ipconfig.exe /flushdns
2021-04-01 06:29:01 C:\WINDOWS\system32\ipconfig.exe /registerdns
2021-04-01 06:29:04 End ipconfig commands for register-dns...

Dusseldorf, France and London are fine.

Thank you.

User avatar
df
Site Admin
Posts: 472
Joined: Thu Jan 01, 1970 5:00 am

Re: Switzerland node - error connecting to some sites

Post by df » Thu Apr 01, 2021 2:44 am

The Switzerland server was down for 1 hour and 40 minutes yesterday because I was migrating it to the new Arch Linux setup. Normally doesn't take that long, but ran into some issues. It should be good now.

Moonlight

Re: Switzerland node - error connecting to some sites

Post by Moonlight » Thu Apr 01, 2021 7:21 am

Strange, I had timing issues since 30/3, must be something else.

Main thing is it's working now! :thumbup:

Thank you.

Post Reply