Ξ welcome to cryptostorm's member forums ~ you don't have to be a cryptostorm member to post here Ξ
Ξ any OpenVPN configs found on the forum are likely outdated. For the latest, visit here or GitHub Ξ
Ξ If you're looking for tutorials/guides, check out the new https://cryptostorm.is/#section6 Ξ

VirtualBox Kubuntu VM not allowing LAN access with CS

Looking for assistance with a cryptostorm connection issue? Post here & we'll help out. Also: if you're not sure where to post, do so here & we'll move things around as needed. Also: for quickest support, email our oddly calm & easygoing support reps at support@cryptostorm.is :)

Topic Author
MOQ888
Posts: 59
Joined: Sun Apr 02, 2017 6:31 pm

VirtualBox Kubuntu VM not allowing LAN access with CS

Post by MOQ888 » Sun Jun 23, 2019 9:02 am

My normal kubuntu 18.04 PC is working beautifully with ED25519 kill switch configs, thanks to DF's superb help.

A few months back I set up a kubuntu VM on my Win desktop and it accesses the LAN fine until I connect to CS through NM (old RSA configs, no kill switching). While connected through CS everything behaves normally for web access, etc., it just refuses to talk to other LAN IPs and after disconnecting CS the LAN access resumes.

Today I fired up the VM and one of the Ubuntu updates was OpenSSL 1.1.1 (11 Sept 2018, I'll update from source to 1.1.1b later). So one less impediment to ED25519 transition from NM RSA on the VM, plus I wanted to document the procedure for future reference as it is a bit involved (f**king DNSmasq ...). The VM is sorted and connects to the Internet quite happily but the inability to connect to my LAN remains.

The VBox VM LAN IF comes up with its own 10.0.2.xx address, I guess the virtual NIC does the routing to the LAN (192.168.xxx.xxx). I tried playing around with the Network Adaptor configurations for the VM but it got really unhappy, had to leave it on NAT.

Is this a limitation of using VBox VMs with CS and is there a way round it? It's not a huge bother, it'd just be nice to access the LAN while I'm connected to CS, but if I have to finish what I'm doing and then disconnect, so be it.



Topic Author
MOQ888
Posts: 59
Joined: Sun Apr 02, 2017 6:31 pm

Re: VirtualBox Kubuntu VM not allowing LAN access with CS

Post by MOQ888 » Sun Jun 30, 2019 3:33 pm

It's NAT, should I try bridged?


Topic Author
MOQ888
Posts: 59
Joined: Sun Apr 02, 2017 6:31 pm

Re: VirtualBox Kubuntu VM not allowing LAN access with CS

Post by MOQ888 » Tue Jul 02, 2019 3:09 pm

DOH ... I switched it from NAT to Bridged and of course it works perfectly. Tks PB!

User avatar

parityboy
Site Admin
Posts: 1215
Joined: Wed Feb 05, 2014 3:47 am

Re: VirtualBox Kubuntu VM not allowing LAN access with CS

Post by parityboy » Sun Jul 07, 2019 1:01 am

MOQ888 wrote:
Tue Jul 02, 2019 3:09 pm
DOH ... I switched it from NAT to Bridged and of course it works perfectly. Tks PB!
yw. :D

Post Reply