Search found 22 matches

by lajola
Sat Apr 10, 2021 1:54 am
Forum: cryptostorm in-depth: announcements, how it works, what it is
Topic: widget v3
Replies: 277
Views: 1406687

Re: widget v3

df wrote:
Sat Apr 10, 2021 1:38 am
Can you run the widget on the host system?
Eh.. it's impossible for me. :cry: I have only a mac. For this i have asked some times a osx widget.
by lajola
Sat Apr 10, 2021 12:33 am
Forum: cryptostorm in-depth: announcements, how it works, what it is
Topic: widget v3
Replies: 277
Views: 1406687

Re: widget v3

Windows 10 on Parallels
by lajola
Sat Apr 10, 2021 12:23 am
Forum: cryptostorm in-depth: announcements, how it works, what it is
Topic: widget v3
Replies: 277
Views: 1406687

Re: widget v3

df wrote:
Sat Apr 10, 2021 12:17 am
I mean are you using any other VPN software? Most of them make the assumption that their TAP adapter is the only one that'll ever be installed, so they'll often trample all over other adapters, changing settings arbitrarily etc.
The only vpn that i am using, on virtual machine, using tap adapter is cryptostorm. And how written in previous posts i have try with many tap drivers. Now i am using the last stable linked by you.
by lajola
Sat Apr 10, 2021 12:13 am
Forum: cryptostorm in-depth: announcements, how it works, what it is
Topic: widget v3
Replies: 277
Views: 1406687

Re: widget v3

df wrote:
Sat Apr 10, 2021 12:08 am
What about other VPN software? And when you say you never see csvpn.exe, does that include when you're connected? Because it has to be in the process list if you're connected.
I edited previous post. I see csvpn.exe and it is there without problems. Other vpn software have no problem.
by lajola
Sat Apr 10, 2021 12:04 am
Forum: cryptostorm in-depth: announcements, how it works, what it is
Topic: widget v3
Replies: 277
Views: 1406687

Re: widget v3

df wrote:
Fri Apr 09, 2021 11:24 pm
Trying again with last new tap driver linked previously. With new tap driver i see this thing: only if i exit from widget the tap goes in disconnect and standard connection is working again. We need a way to avoid this EXIT continually from widget to have again standard connection and reopen it again every time we need the vpn connection.
So when you click the Disconnect button on the widget the TAP adapter is still in a connected state? It only leaves that state when you exit? I'm not seeing that behavior on Windows 10:
widget.gif
EDIT:
The TAP adapter should be unplugged/disconnected whenever OpenVPN (csvpn.exe) exits. The widget forcibly kills that process using a couple of different methods. Maybe an AV or something is preventing that from happening? When you disconnect, check if csvpn.exe is still in the process list by opening the task manager with ctrl+shift+escape then clicking on the Details tab, see if there's a csvpn.exe in there still.
Yes.

I see csvpn.exe. I have only windows standard antivirus and also disabling it nothing changes. I don't know honestly. But this is a big bug on my side.
by lajola
Fri Apr 09, 2021 10:58 pm
Forum: cryptostorm in-depth: announcements, how it works, what it is
Topic: widget v3
Replies: 277
Views: 1406687

Re: widget v3

Trying again with last new tap driver linked previously. With new tap driver i see this thing: only if i exit from widget the tap goes in disconnect and standard connection is working again. We need a way to avoid this EXIT continually from widget to have again standard connection and reopen it again every time we need the vpn connection.
There is also a second problem: after the first vpn connection and then disconnected, also if tap adapter seems still connected it's impossible make a new vpn connection because there is not internet at this moment, non standard connection also obviously. So also here the only way is completely EXIT from widget and then reopen it to have again both standard connection or a the possibility to make a vpn connection.
This also with the last stable tap driver, with the standard one incluse in the crypto widget bug are bigger.

With this last we need a way that when we disconnect from widget the tap must disconnect itself. In this way all is solved/fixed. Because now tap driver disconnect itself only if we EXIT from widget. Why?
by lajola
Fri Apr 09, 2021 10:54 pm
Forum: cryptostorm in-depth: announcements, how it works, what it is
Topic: widget v3
Replies: 277
Views: 1406687

Re: widget v3

df wrote:
Fri Apr 09, 2021 10:53 pm
@lajola
forgot to say, when you install the new one, you need to go into network connections and rename that TAP adapter to "cryptostorm"
Yeah done, but problem is still there :( this bug is really tedious
by lajola
Fri Apr 09, 2021 10:15 pm
Forum: cryptostorm in-depth: announcements, how it works, what it is
Topic: widget v3
Replies: 277
Views: 1406687

Re: widget v3

This new tap version doesn't solve the problem. Not only, when i try the crypto connection the widget install the own tap driver so now i have 2 tap drivers connected and enabled together. When i disconnect from widget now both remain enabled and the vpn connection is still ENABLED! So with this new one problem is still there.
Please you need to solve this bug with windows 10.

Edit: now i have uninstalled all tap drivers but now when i try to connect from widget, this last can not install its tap driver anymore. So no more connection with vpn. So how can solve this problem?

Edit2: installed the "original" from cryptostorm folder in /Programs
by lajola
Fri Apr 09, 2021 12:50 am
Forum: cryptostorm in-depth: announcements, how it works, what it is
Topic: widget v3
Replies: 277
Views: 1406687

Re: widget v3

Ok these are the problems:

1) reboot windows
2) connect with cryptostorm widget
3) disconnect with cryptostorm widget
4) web surfing/connection is not more available
---
5) cryptostorm tap adapter is still ENABLED but CONNECTED
6) manullay disabled it
7) manually enabled it again but now is DISCONNECTED
8) now web surfing/connection is available and working!
---
9) tried again a new vpn cryptostorm connection but doesn't work because widget can't move the TAP adapter from ENABLED(disconnected) to CONNECTED
10) close widget
11) reopen widget and try a new connection
12) now cryptostorm widget can move the TAP adapter from ENABLED(disconnected) to CONNECTED
13) VPN is working
---
14) from point 3

Now why widget can't do all this automatically?
by lajola
Fri Apr 09, 2021 12:18 am
Forum: cryptostorm in-depth: announcements, how it works, what it is
Topic: widget v3
Replies: 277
Views: 1406687

Re: widget v3

df wrote:
Fri Apr 09, 2021 12:14 am
I tested on Windows 10, not seeing the issue you're describing. Check in Options -> Security and see if the kill switch is enabled. The kill switch uses the Windows Firewall, so even if you've never used it before there might be some old rules leftover in there from the widget. Try disabling DNSCrypt in there too. If that's enabled and the DNS isn't getting restored on disconnect then it would cause DNS failures. There's also a big button in Options -> Advanced that says "Reset DNS to DHCP". Try clicking that after disconnecting and see if your internet works then.
Tried. KS was disabled like all other options.
"Reset DNS to DHCP" doesn't fix the problem. Tried many times. It deletes my google dns insert by me.

Which are the kill switch rules remained in the firewall?
by lajola
Fri Apr 09, 2021 12:03 am
Forum: cryptostorm in-depth: announcements, how it works, what it is
Topic: widget v3
Replies: 277
Views: 1406687

Re: widget v3

Yes, same problem with last version 3.47.0.49.
The first connection with the widget works without problems. But after disconnected there is no more connection. Nothing. The only way is a windows reboot.
Don't remember if kill switch was enabled. I use the standard windows 10 firewall and i never touched it.

So what you need to fix this weird bug? I can't reboot honestly every connection.
by lajola
Thu Apr 08, 2021 10:26 pm
Forum: cryptostorm in-depth: announcements, how it works, what it is
Topic: widget v3
Replies: 277
Views: 1406687

Re: widget v3

I have had this problem for many versions, I don't remember when it started, obviously I'm on windows 10: the first connection to a server is always successful, but after I have disconnected there is no longer an internet connection working even if there are no obvious errors. In fact, if I try to reconnect the vpn the app crashes on "Connecting". As if there was a DNS problem. Basically it is impossible to navigate, tried anything. The only way to browse again is to reboot the system.
by lajola
Sat Mar 27, 2021 9:06 am
Forum: general chat, suggestions, industry news
Topic: Suggestion servers and routing
Replies: 1
Views: 1948

Suggestion servers and routing

3 things:
. if possible to add more city/servers to country like German, Switzerland, Holland, France, and Sweden.
. add some good server to enable i.e. BBCIplayer from UK servers, Zattoo from German, Switzerland, etc..
. add some extra exotic server like Russia, Belarus, Armenia, Estonia, Luxemburg, Africa server like in this vpn: https://nvpn.net/order.php?step=1

Thanks @df
by lajola
Fri Mar 26, 2021 4:57 am
Forum: member support & tech assistance
Topic: Wireguard connection problem
Replies: 13
Views: 4100

Re: Wireguard connection problem

df wrote:
Fri Mar 26, 2021 2:09 am
lajola wrote: @df

i have this error after maked 6 wireguard connection:

Error: That token is limited to 6 wireguard keys,
and there's already 6 keys in the system.
Go here if you need to delete your other keys.

So we can not add and use all servers like in other vpns?
You're confusing connections with keys. What you're doing on that page isn't making connections, it's making keys. Each key gets added to all of our servers so that you can connect to any of them using that key. Each cryptostorm token can only have a certain number of keys associated with it. The page at https://cryptostorm.is/blog/wireguard-support-added under "Device limits" show the number of WireGuard keys that are allowed for each cryptostorm token type (in your case, 6). WireGuard won't allow you to connect to more than one server on the same device (at the same time), but we don't have any network-wide connection limits, so technically you could (for example) have 30 devices each using the same key and connecting to different servers.
Understood now. All tunnels config and working. Thanks ;)
by lajola
Fri Mar 26, 2021 1:44 am
Forum: member support & tech assistance
Topic: Wireguard connection problem
Replies: 13
Views: 4100

Re: Wireguard connection problem

@df

i have this error after maked 6 wireguard connection:

Error: That token is limited to 6 wireguard keys,
and there's already 6 keys in the system.
Go here if you need to delete your other keys.

So we can not add and use all servers like in other vpns?
by lajola
Sat Mar 20, 2021 9:34 pm
Forum: member support & tech assistance
Topic: Wireguard connection problem
Replies: 13
Views: 4100

Re: Wireguard connection problem

df wrote:
Sun Mar 14, 2021 11:30 am
I just checked the servers, the Manchester node's WireGuard peer list was out of sync with the others. Looks like it was missing from the backend API that updates the nodes when new peers get added/deleted. That's fixed now, so if you were trying the Manchester node, try again and it should work.

If that's not the node you were on and another WireGuard VPN works fine, then my guess is that the PSK or IP is incorrect. Did you try creating a new one @ cryptostorm.is/wireguard ?
I tried everything until today and always the same problem. Really i don't know what still i can try ... With other wireguard vpn i have no problems.
If we have a good widget also for osx and with wireguard support we will haven't problems :yawn:
by lajola
Sat Mar 20, 2021 9:32 pm
Forum: cryptostorm in-depth: announcements, how it works, what it is
Topic: widget v3
Replies: 277
Views: 1406687

Re: widget v3

Why we haven't a good widget also for Osx? I can't understand. Please @df buy a mac, we need a good widget also for Osx. Or buy a dev to do it, it's necessary.
by lajola
Sun Mar 14, 2021 11:17 am
Forum: member support & tech assistance
Topic: Wireguard connection problem
Replies: 13
Views: 4100

Re: Wireguard connection problem

Weird. I tried my other Wireguard VPN and all works well. I also disabled adguard, littlesnitch and all the possible, but always the same problem. I don't know what to do. I checked double the wireguard conf, etc.. and seems all configurated in the right way.
by lajola
Fri Mar 12, 2021 7:06 pm
Forum: member support & tech assistance
Topic: Wireguard connection problem
Replies: 13
Views: 4100

Wireguard connection problem

I have a big problem with Wireguard. I am on Catalina. I set all like in this page: https://cryptostorm.is/wireguard many times.
I have done all kind of tries but I can't surf in any way.

This is the log:
https://workupload.com/file/tNMQkpc2gKb

I need help.
by lajola
Thu Mar 11, 2021 3:18 pm
Forum: member support & tech assistance
Topic: Cryptostorm network - news
Replies: 30
Views: 70453

Re: Cryptostorm network - news

df wrote:
Thu Mar 11, 2021 4:09 am
@lajola
Haven't heard back from jedisct1 yet. You'll see that error if you're running dnscrypt-proxy at the console/terminal. I haven't tested any GUI frontends for dnscrypt-proxy, so not sure what it would look like in those. If you get that error, then add to your config "force_tcp = true". If you don't see it anywhere in your terminal or the log files, then don't worry about it.
Ok thanks :thumbup:
by lajola
Thu Mar 11, 2021 3:17 pm
Forum: guides, HOWTOs & tutorials
Topic: Wireguard connection problem
Replies: 0
Views: 2417

Wireguard connection problem

I have a big problem with Wireguard. I am on Catalina. I set all like in this page: https://cryptostorm.is/wireguard many times.
I have done all kind of tries but I can't surf in any way.

This is the log:
https://workupload.com/file/tNMQkpc2gKb

I need help.
by lajola
Wed Mar 10, 2021 7:48 pm
Forum: member support & tech assistance
Topic: Cryptostorm network - news
Replies: 30
Views: 70453

Re: Cryptostorm network - news

df wrote:
Fri Feb 26, 2021 2:50 pm

The dnscrypt files on https://github.com/cryptostorm/cstorm_deepDNS/ are updated now too, but there's an issue going on with some of the relays, something to do with UDP fragmentation that's occuring, or being reported as occuring by dnscrypt-proxy. I left a message about it for jedisct1 (the guy that wrote dnscrypt-proxy), maybe he'll know what's going on there. So if you're trying to use our Anonymous DNS relays (relays.md) and you get a "[another DNS server] couldn't be reached anonymously" error, then just add to your dnscrypt-proxy.toml the line "force_tcp = true" and it'll stop using UDP, which gets past that error.
Hi, this problem has been solved? Do you have contacted jedisct1?

I am on OSX, how can check if i have this error: [another DNS server] couldn't be reached anonymously" error


Thank you