Ξ welcome to cryptostorm's member forums ~ you don't have to be a cryptostorm member to post here Ξ
Ξ any OpenVPN configs found on the forum are likely outdated. For the latest, visit here or GitHub Ξ
Ξ If you're looking for tutorials/guides, check out the new https://cryptostorm.is/#section6 Ξ

Search found 4 matches

by deadbeef
Fri Nov 23, 2018 3:22 am
Forum: member support & tech assistance
Topic: Probs with new configs in Ubuntu
Replies: 28
Views: 18206

Re: Probs with new configs in Ubuntu

I decided to bite the bullet and update Buster as advised. And can confirm it works. OpenVPN 2.4.6 x86_64-pc-linux-gnu [SSL (OpenSSL)] [LZO] [LZ4] [EPOLL] [MH/PKTINFO] [AEAD] built on Nov 22 2018 library versions: OpenSSL 1.1.1 11 Sep 2018, LZO 2.10 Much thanks. I chose the Ed448 configs. Things fee...
by deadbeef
Thu Nov 22, 2018 2:04 am
Forum: member support & tech assistance
Topic: Probs with new configs in Ubuntu
Replies: 28
Views: 18206

Re: Probs with new configs in Ubuntu

Aha! OpenSSL> version OpenSSL 1.1.1 11 Sep 2018 OpenVPN 2.4.6 x86_64-pc-linux-gnu [...] library versions: OpenSSL 1.0.2o Have learnt to be especially cautious. Was stressing about going ahead, which you kinda anticipated. Glad I slept on it and checked back in. I'll read up on "apt exclude". Thanks ...
by deadbeef
Wed Nov 21, 2018 3:35 am
Forum: member support & tech assistance
Topic: Probs with new configs in Ubuntu
Replies: 28
Views: 18206

Re: Probs with new configs in Ubuntu

Much thanks. Buster does have openssl 1.1.1 and openvpn 2.4.6 in its repos. I have them installed but for some quirky reason I don't have the skills to fathom it reverts to (as per terminal sesh): OpenVPN 2.4.6 x86_64-pc-linux-gnu [SSL (OpenSSL)] [LZO] [LZ4] [EPOLL] [PKCS11] [MH/PKTINFO] [AEAD] buil...
by deadbeef
Wed Nov 21, 2018 3:20 am
Forum: member support & tech assistance
Topic: Probs with new configs in Ubuntu
Replies: 28
Views: 18206

Re: Probs with new configs in Ubuntu

I was using Debian 9 stable and moved to Buster because of this problem with OpenVPN 2.4.6 and below defaulting to an OpenSSL lower than 1.1.1

Upgrading didn't fix it for me.

To use the latest encryption requires 1.1.1 of course.

Puzzles me how upgrading Ubuntu would fix it.