Ξ welcome to cryptostorm's member forums ~ you don't have to be a cryptostorm member to post here Ξ
Ξ any OpenVPN configs found on the forum are likely outdated. For the latest, visit here or GitHub Ξ
Ξ If you're looking for tutorials/guides, check out the new https://cryptostorm.is/#section6 Ξ

Search found 59 matches

by MOQ888
Tue Jul 02, 2019 3:09 pm
Forum: member support & tech assistance
Topic: VirtualBox Kubuntu VM not allowing LAN access with CS
Replies: 4
Views: 281

Re: VirtualBox Kubuntu VM not allowing LAN access with CS

DOH ... I switched it from NAT to Bridged and of course it works perfectly. Tks PB!
by MOQ888
Sun Jun 23, 2019 9:02 am
Forum: member support & tech assistance
Topic: VirtualBox Kubuntu VM not allowing LAN access with CS
Replies: 4
Views: 281

VirtualBox Kubuntu VM not allowing LAN access with CS

My normal kubuntu 18.04 PC is working beautifully with ED25519 kill switch configs, thanks to DF's superb help. A few months back I set up a kubuntu VM on my Win desktop and it accesses the LAN fine until I connect to CS through NM (old RSA configs, no kill switching). While connected through CS eve...
by MOQ888
Mon May 27, 2019 5:38 am
Forum: member support & tech assistance
Topic: Circuit Breaker
Replies: 24
Views: 2113

Re: Circuit Breaker

Thanks as always DF, it was the 4GX being used at the time. Handy do know about the --daemon switch, I'll mod my .sh to include that. I had saved the configs in separate dirs so I won't confuse myself, over the next few days will start modifying the rest of them for the kill switch commands. I guess...
by MOQ888
Fri May 24, 2019 3:18 pm
Forum: member support & tech assistance
Topic: Circuit Breaker
Replies: 24
Views: 2113

Re: Circuit Breaker

Connection seems to work fine, even on the 4GX device, although I get a ton of these messages in the Terminal box that launched the VPN connection *** Fri May 24 20:16:42 2019 us=590034 PID_ERR large diff [64] [SSL-0] [0______________________0__0___0_________________________________] 0:2004335 0:200...
by MOQ888
Fri May 24, 2019 2:57 pm
Forum: member support & tech assistance
Topic: Circuit Breaker
Replies: 24
Views: 2113

Re: Circuit Breaker

OK, lots more happening after this ... The stub-resolv.conf didn't survive reboot, I found a page that described how to disable systemd-resolved. Edited resolv.conf and the VPN connected. Reboot, failed. Under these circumstances NetworkManager overwrites resolv.conf each reboot. So in NetworkManage...
by MOQ888
Fri May 24, 2019 1:17 pm
Forum: member support & tech assistance
Topic: Circuit Breaker
Replies: 24
Views: 2113

Re: Circuit Breaker

I (root) managed to edit /run/systemd/resolve/stub-resolv.conf and now I am able to successfully connect after following the instructions, thank you DF for all your assistance, greatly appreciated! cryptostorm.is/test and cryptostorm.is/dnsleaktest return as expected. I have to launch a new root Ter...
by MOQ888
Thu May 23, 2019 5:30 am
Forum: member support & tech assistance
Topic: Circuit Breaker
Replies: 24
Views: 2113

Re: Circuit Breaker

I think it's got something to do with Ubuntu not allowing me access to resolv.conf, here's what I get as root in Terminal root@e8100-i7:/etc# lsattr resolv.conf lsattr: Operation not supported While reading flags on resolv.conf root@e8100-i7:/etc# chattr -i resolv.conf chattr: Operation not supporte...
by MOQ888
Wed May 22, 2019 3:28 pm
Forum: member support & tech assistance
Topic: Circuit Breaker
Replies: 24
Views: 2113

Re: Circuit Breaker

Having problems understanding the Terminal instructions in https://cryptostorm.is/nix#terminal. Using ED25519 UDP configs. I'm at the point where the author talks about Ubuntu dnsmasq. So I execute the openvpn command for my chosen server and receive the Initialisation Sequence Completed message, an...
by MOQ888
Wed May 15, 2019 5:24 pm
Forum: member support & tech assistance
Topic: Circuit Breaker
Replies: 24
Views: 2113

Re: Circuit Breaker

I'll try using the terminal to connect later this week, maybe it's just NM. If that works I'll move away from the RSA configs.
by MOQ888
Wed May 15, 2019 5:18 pm
Forum: member support & tech assistance
Topic: Circuit Breaker
Replies: 24
Views: 2113

Re: Circuit Breaker

the grep command correctly identified the line KS_lan_up.sh (I renamed it) in the /usr/local/bin folder root@e8100-i7:/usr/local/bin# ls -l total 1696 -rwxr-xr-x 1 root root 1970 May 15 21:01 KS_lan_up.sh it looks executable to me so I thought it "should" run for non-root login the iptables command ...
by MOQ888
Wed May 15, 2019 5:01 pm
Forum: member support & tech assistance
Topic: Circuit Breaker
Replies: 24
Views: 2113

Re: Circuit Breaker

I'll check the config again, those up/down lines were at the end of the std configs but it won't hurt to check. Is there a way I can check the update-resolv-config after I disconnect the VPN to see what it's doing? This is what iptables -L gave me while I'm connected now Chain INPUT (policy ACCEPT) ...
by MOQ888
Wed May 15, 2019 4:38 pm
Forum: member support & tech assistance
Topic: Circuit Breaker
Replies: 24
Views: 2113

Re: Circuit Breaker

Tks DF. There must be something in NM, I did the killall and it can still ping 8.8.8.8. The script-security 2 was included but AFTER the up/down lines as per the CS website instructions, whereas it was before the up/down lines in the standard cfg. Would that make a difference? I'll try connecting vi...
by MOQ888
Wed May 15, 2019 4:19 pm
Forum: member support & tech assistance
Topic: Circuit Breaker
Replies: 24
Views: 2113

Re: Circuit Breaker

OK, I modified one .ovpn config with the up and down script references and it connects fine. I was curious if I could ping 8.8.8.8 through my LAN IF if I manually disconnected the VPN and it does. So I deleted that one in NM and commented out the down line in the .ovpn cfg, and recreated it. Connect...
by MOQ888
Tue May 14, 2019 3:45 am
Forum: member support & tech assistance
Topic: Circuit Breaker
Replies: 24
Views: 2113

Re: Circuit Breaker

Tks DF!
by MOQ888
Mon May 13, 2019 5:32 pm
Forum: member support & tech assistance
Topic: Circuit Breaker
Replies: 24
Views: 2113

Re: Kill Switch

Today I discovered there is actually a Kill Switch section on the website! I'm looking at scenario #3, and in the section where I need to make adjustments to the .ovpn file it suggests adding up /usr/local/bin/killswitch_system_lan_up.sh down /usr/local/bin/killswitch_system_lan_up.sh script-securit...
by MOQ888
Sat Apr 27, 2019 8:39 am
Forum: member support & tech assistance
Topic: IPLeak.net broken?
Replies: 16
Views: 2448

Re: IPLeak.net broken?

I haven't noticed that issue, but I don't use ipleak.net often. My go to is usually dnsleaktest.com. I used ipleak.net because it was listed in the cryptostorm.is/map page that I look at to grab info if I have to run up a new machine. Since it appears problematic maybe it can be removed and the CS ...
by MOQ888
Mon Apr 22, 2019 6:37 am
Forum: member support & tech assistance
Topic: IPLeak.net broken?
Replies: 16
Views: 2448

Re: IPLeak.net broken?

Tks for confirming. What's strange for me)in Firefox is that if ipleaks.net starts its DNS leak testing (which is very slow) then no other tab can resolve any DNS hosts. Closing FF and relaunching it sorts this weirdness. Haven't tried another browser. During this I can resolve and ping host names i...
by MOQ888
Sat Apr 20, 2019 1:40 pm
Forum: member support & tech assistance
Topic: IPLeak.net broken?
Replies: 16
Views: 2448

IPLeak.net broken?

Over the last few days I've noticed that ipleak.net fails on all the DNS Leak tests. At first I thought it was because I installed RealVNC on this Kubuntu box but I tested on a Win10 PC and its Kubuntu VM and both fail in the same way. I've found other DNS Leak pages but I was wondering what others ...
by MOQ888
Sat Mar 02, 2019 4:16 pm
Forum: member support & tech assistance
Topic: Circuit Breaker
Replies: 24
Views: 2113

Re: Circuit Breaker

don't worry, I have since discovered this is called a Kill Switch and DF has already posted an example.
by MOQ888
Sat Mar 02, 2019 8:29 am
Forum: member support & tech assistance
Topic: Circuit Breaker
Replies: 24
Views: 2113

Circuit Breaker

A while back PB (I think) mentioned setting up *nix with some kind of circuit breaker (?) to kill all traffic if the VPN dropped out. I'm very interested in implementing this. I've tried searching "VPN circuit breaker" but I suspect my terminology is wrong. Is there a resource our some pointers I ca...
by MOQ888
Thu Jan 03, 2019 1:20 pm
Forum: member support & tech assistance
Topic: TorrentIP
Replies: 3
Views: 3026

Re: TorrentIP

Thanks DF, just happened to check it and AOK.

Any chance of some different skins for the forum at some stage? I took a look around under my UCP settings and didn't see anything - not urgent of course.
by MOQ888
Tue Jan 01, 2019 4:14 am
Forum: member support & tech assistance
Topic: TorrentIP
Replies: 3
Views: 3026

TorrentIP

Is it broken, or is it me? Tried it on both my connections and nothing comes up on the browser, and I get an "Internal Server Error" message for the tracker.
by MOQ888
Tue Jan 01, 2019 4:11 am
Forum: member support & tech assistance
Topic: ISP blocking all other DNS
Replies: 4
Views: 5371

Re: ISP blocking all other DNS

Must have been a transient issue ... used the hotspot again just now, connected to US_LA_UDP and ipleak showed both the ISP and CS DNS.

HNY Everyone!
by MOQ888
Tue Dec 25, 2018 4:50 am
Forum: member support & tech assistance
Topic: ISP blocking all other DNS
Replies: 4
Views: 5371

ISP blocking all other DNS

Just noticed this when using my backup connection (4GX hotspot). The Australian Government wants all ISPs to block access to "bad" sites and this is achieved by DNS blocking. Works for most attempts. I typically use my normal connection to get onto CS, and sometimes use the 4GX hotspot to connect to...
by MOQ888
Fri Nov 02, 2018 2:08 pm
Forum: member support & tech assistance
Topic: Probs with new configs in Ubuntu
Replies: 28
Views: 17892

Re: Probs with new configs in Ubuntu

Quite enjoying KDE in Kubuntu, its network manager is so much better - it remembers recent connections and moves them to the top of the very long CS list, just brilliant since my preferred connection is Washington DC, which is always at the very bottom of Ubuntu's Gnome NM. I know, it's just a scrol...
by MOQ888
Tue Oct 30, 2018 4:53 pm
Forum: member support & tech assistance
Topic: Probs with new configs in Ubuntu
Replies: 28
Views: 17892

Re: Probs with new configs in Ubuntu

kubuntu up and running, CS working well - HOORAY!
by MOQ888
Tue Oct 30, 2018 1:57 pm
Forum: member support & tech assistance
Topic: Probs with new configs in Ubuntu
Replies: 28
Views: 17892

Re: Probs with new configs in Ubuntu

If your VPN connections originate in the router I doubt if you'll experience the problems I've been having. I've downloaded Kubuntu 18.04 ISO just now. I think I'll prefer KDE as I was used to using it way back in Solaris days (if my memory serves me correctly). I got used to Unity but I don't think...
by MOQ888
Tue Oct 30, 2018 12:40 pm
Forum: member support & tech assistance
Topic: Probs with new configs in Ubuntu
Replies: 28
Views: 17892

Re: Probs with new configs in Ubuntu

Seem to have repaired the weirdness of NM by removing the LAN profile for the 4G hotspot. Despite me setting explicitly the primary LAN as auto-connect, seems that 18.04 or NM didn't really understand that. I did set up this install using the 4G hotspot as my primary LAN is so slow. Could be that it...
by MOQ888
Tue Oct 30, 2018 12:25 pm
Forum: member support & tech assistance
Topic: Probs with new configs in Ubuntu
Replies: 28
Views: 17892

Re: Probs with new configs in Ubuntu

"working" ... sort of. Started having the same issues with the fresh 18.04 install, SO frustrating! Turns out the problem all along is that the domain hosts for the new CS servers are all classified by Fortinet as "newly observed domains". By removing this rule in the DNS filter finally allowed me t...
by MOQ888
Sun Oct 28, 2018 2:36 pm
Forum: member support & tech assistance
Topic: Probs with new configs in Ubuntu
Replies: 28
Views: 17892

Re: Probs with new configs in Ubuntu

Ubuntu 18.04 reinstalled fresh, all working as it should.

Suspect the problem was something lingering in the 16.04 install.
by MOQ888
Sun Oct 28, 2018 6:34 am
Forum: member support & tech assistance
Topic: Probs with new configs in Ubuntu
Replies: 28
Views: 17892

Re: Probs with new configs in Ubuntu

grumble ... Took ages to upgrade from 16.04 to 18.04, of course as soon as I left the machine overnight prompts appeared. There seems to be some weirdness left over from 16.04 install, despite re-importing all the RSA configs just like I did on the test install, they still fail due to wanting to loo...
by MOQ888
Sat Oct 27, 2018 1:55 pm
Forum: member support & tech assistance
Topic: Probs with new configs in Ubuntu
Replies: 28
Views: 17892

Re: Probs with new configs in Ubuntu

Another problem is that 208.91.112.55 IP you're connecting to. That's not in the Washington DC list of IPs: That confused me for a while, I had no idea why it was doing that. Then I was having problems with CS on the temp 18.04 install after a reboot and an nslookup on one of my domain hosts (that ...
by MOQ888
Sat Oct 27, 2018 12:34 pm
Forum: member support & tech assistance
Topic: Probs with new configs in Ubuntu
Replies: 28
Views: 17892

SOLVED (kind of)

Ran up a fresh install of Unbuntu 18.04 on a spare disk, after following the NM instructions for RSA configs, and CS WORKS! Now just have to reinstate the old drive, backup files and upgrade from 16.04, but this fresh install works perfectly. Ubuntu repository default versions OpenVPN 2.4.4, OpenSSL...
by MOQ888
Sat Oct 27, 2018 7:07 am
Forum: member support & tech assistance
Topic: Probs with new configs in Ubuntu
Replies: 28
Views: 17892

Re: Probs with new configs in Ubuntu

went from bad to worse ... I uninstalled OpenVPN and reinstalled, then any attempt to connect to the old CS servers clobbered NM. Rebooting was fine, default network still allowed me to access through my LAN, but couldn't use CS at all. Removed/Purged OpenVPN 2.4.6 and got the system back to OpenVPN...
by MOQ888
Fri Oct 26, 2018 4:24 pm
Forum: member support & tech assistance
Topic: Probs with new configs in Ubuntu
Replies: 28
Views: 17892

Re: Probs with new configs in Ubuntu

tried using ECC configs from Terminal, no joy either

Same openssl library version 1.0.2g.

Should I try installing OpenVPN 2.4.6 again, maybe it'll pull in the correct openssl library now that it's 1.1.1 ... ?
by MOQ888
Fri Oct 26, 2018 4:01 pm
Forum: member support & tech assistance
Topic: Probs with new configs in Ubuntu
Replies: 28
Views: 17892

Re: Probs with new configs in Ubuntu

Ok, I deleted all the previous config folders, downloaded the config.zip from the RSA folder above. I updated openssl to 1.1.1 Created US-WashingtonDC_UDP in NM and fails again, syslog attached. Curiously, in the syslog nm-openvpn[4374] reports library version as OpenSSL 1.0.2g despite me confirming...
by MOQ888
Fri Oct 26, 2018 4:56 am
Forum: member support & tech assistance
Topic: Probs with new configs in Ubuntu
Replies: 28
Views: 17892

Re: Probs with new configs in Ubuntu

That usually means you downloaded the HTML version of the config from Github and not the raw version. or you could just grab them from our website @ https://cryptostorm.is/configs/ since the configs there don't have an HTML version. That's the weird thing, I had originally downloaded both config.zi...
by MOQ888
Tue Oct 23, 2018 2:02 pm
Forum: member support & tech assistance
Topic: Probs with new configs in Ubuntu
Replies: 28
Views: 17892

Re: Probs with new configs in Ubuntu

Thanks for your input PB. As suggested I created a TLS.txt file and pasted the key, pointed Additional TLS info to the file but still no joy. Thought I'd try adding one from scratch (Seattle) with the same key but same. Attachment 20181023-1 was for the existing Washington connection, 20181023-2 was...
by MOQ888
Mon Oct 22, 2018 3:47 pm
Forum: member support & tech assistance
Topic: Probs with new configs in Ubuntu
Replies: 28
Views: 17892

Re: Probs with new configs in Ubuntu

Tks PB, syslog attached
by MOQ888
Sat Oct 20, 2018 4:14 pm
Forum: member support & tech assistance
Topic: Probs with new configs in Ubuntu
Replies: 28
Views: 17892

Probs with new configs in Ubuntu

Hi guys, I've been trying to set up the new configs as per the instructions but having no luck. Ubuntu 1604, OpenVPN 2.4.6 Tried the import into Network Manager and all RSA configs imported OK but can't connect (times out). Tried the Terminal method to launch ECC and can't connect. Tried using the s...
by MOQ888
Wed Jul 25, 2018 9:59 am
Forum: cryptostorm in-depth: announcements, how it works, what it is
Topic: Tokens - recurring vs 1-shot
Replies: 3
Views: 12150

Re: Tokens - recurring vs 1-shot

no opinions either way, or have I posted this in the wrong thread?
by MOQ888
Fri Jul 13, 2018 4:05 pm
Forum: cryptostorm in-depth: announcements, how it works, what it is
Topic: Tokens - recurring vs 1-shot
Replies: 3
Views: 12150

Tokens - recurring vs 1-shot

I've been using 1-shot tokens for a few years now and the current one is due to expire soon. I noticed that there is now a Lifetime 1-shot token, which I am considering as I'm totally happy with CS and the fantastic support its community offers. In the thread describing the token system one of the i...
by MOQ888
Thu Mar 29, 2018 9:17 am
Forum: member support & tech assistance
Topic: Slow connection after upgrading to widget 3.12
Replies: 13
Views: 15533

Re: Slow connection after upgrading to widget 3.12

As suggested by PB, I upgraded to 3.15.xx. It connects cleanly but sadly the speeds through CS Widget are still similar to before

US Sth server, TX Speedtest server, 1.2Mbps
US West server, CA server, 1.5Mbps
by MOQ888
Thu Mar 29, 2018 9:05 am
Forum: member support & tech assistance
Topic: France DNSCrypt Server
Replies: 5
Views: 12523

Re: France DNSCrypt Server

Thanks, 3.15.x widget loses the selectable DNSCrypt droplist but has been connecting cleanly since uninstalling 3.13 and installing 3.15. Had to select "Enable DNS Leak prevention" but that was fine too. So ... connects cleanly - YES, sadly as observed by others, speed degradation is still a problem...
by MOQ888
Tue Mar 27, 2018 10:58 am
Forum: member support & tech assistance
Topic: France DNSCrypt Server
Replies: 5
Views: 12523

Re: France DNSCrypt Server

yes, Windows does have a Telnet client! Managed to telnet to the IP/port specified and it came up with a blank screen, no responses such as the esc char, and when I hit [Enter] Telnet closed. Got the same with 8.8.8.:53 so presumably it is "responding" but maybe something else behind the scenes is p...
by MOQ888
Tue Mar 27, 2018 10:41 am
Forum: member support & tech assistance
Topic: Slow connection after upgrading to widget 3.12
Replies: 13
Views: 15533

Re: Slow connection after upgrading to widget 3.12

99.9% of my time is Windows (I was a corporate IT consultant since MS-DOS and Win 3.1 days), I use Ubuntu to do certain things on a dedicated machine and that's what has CS loaded. I was in the process of getting VirtualBox loaded up with Ubuntu 1604 x64, but gawd it was S L O W. My notebook is an o...
by MOQ888
Mon Mar 26, 2018 7:33 am
Forum: member support & tech assistance
Topic: Slow connection after upgrading to widget 3.12
Replies: 13
Views: 15533

Re: Slow connection after upgrading to widget 3.12

Using Widget 3.13, having a similar speed drop Normal fibre connection, local servers (Auckland NZ) 80Mbps CS US West, LA Speedtest server, 1.5Mbps Coming across the Pacific I expect it to be slower, but not this much. Windows 7 x64 TBH I'm not that fazed, I normally use CS on Ubuntu, but I'm travel...
by MOQ888
Sun Mar 25, 2018 9:46 am
Forum: member support & tech assistance
Topic: France DNSCrypt Server
Replies: 5
Views: 12523

France DNSCrypt Server

Chased my tail for a day on this ... CS Win Widget was working fine then after I installed/uninstalled VirtualBox it refused to connect. VB installs some weirdo networking device so I thought that might have been the problem, but no. Uninstalled Widget, reinstalled Widget, same - as the connection w...
by MOQ888
Tue Apr 18, 2017 8:22 am
Forum: member support & tech assistance
Topic: Ubuntu 16.04 DNS Leaks ...
Replies: 14
Views: 9985

Re: Ubuntu 16.04 DNS Leaks ...

Well I've done some more investigating Booting 16.04 and running a script that drops IPv6 packets before running CS strangely yields IPv4 and IPv6 results in ipleak.net. I expected to see my IPv4 DNS but not the IPv6 ones. When connected to CS before executing Fermi's script, ipleak gives the CS DNS...
by MOQ888
Sat Apr 15, 2017 5:17 pm
Forum: member support & tech assistance
Topic: Ubuntu 16.04 DNS Leaks ...
Replies: 14
Views: 9985

Re: Ubuntu 16.04 DNS Leaks ...

I had added the IPv6 disable lines as directed in the Github notes when I noticed the DNS leaks, and I had previously set IPv6 to none (ignore) for each CS server during setup. My LAN & router have no IPv6 settings, I have my own class-c network that I've had since mid-90s, so I don't know why it ma...
by MOQ888
Fri Apr 14, 2017 12:51 pm
Forum: member support & tech assistance
Topic: Ubuntu 16.04 DNS Leaks ...
Replies: 14
Views: 9985

Re: Ubuntu 16.04 DNS Leaks ...

After adjusting the script to allow the local DNS, unfortunately ipleak.net showed my ISP's (IPv6) DNS again. I can live with non-permanent original iptable script, it's important that I am able to use this machine without the CS iptable changes and it's easy to run the script immediately after conn...
by MOQ888
Fri Apr 14, 2017 9:23 am
Forum: member support & tech assistance
Topic: Ubuntu 16.04 DNS Leaks ...
Replies: 14
Views: 9985

Re: Ubuntu 16.04 DNS Leaks ...

Thanks for this Fermi, I'll give this a go later today.

My main goal is to preserve the ability to use the machine when not connected to CS, and obviously have no DNS leaks when I am connected.
by MOQ888
Thu Apr 13, 2017 5:22 pm
Forum: member support & tech assistance
Topic: Ubuntu 16.04 DNS Leaks ...
Replies: 14
Views: 9985

Re: Ubuntu 16.04 DNS Leaks ...

well I did learn something ... I installed iptables-persistent and did a backup, and confirmed that the backups looked correct (post script). After a reboot iptables -S showed the same but since the local DNS is no longer accepted I was not able to browse when not connected to CS, nor could I connec...
by MOQ888
Thu Apr 13, 2017 3:19 pm
Forum: member support & tech assistance
Topic: Ubuntu 16.04 DNS Leaks ...
Replies: 14
Views: 9985

Re: Ubuntu 16.04 DNS Leaks ...

Thanks Fermi, I'll do some searching to learn about making the changes persistent.
by MOQ888
Thu Apr 13, 2017 12:56 pm
Forum: member support & tech assistance
Topic: Ubuntu 16.04 DNS Leaks ...
Replies: 14
Views: 9985

Re: Ubuntu 16.04 DNS Leaks ...

Thanks for your input crypto_addict, much appreciated. I copied the script, edited the LAN subnet to match mine, and ran it. Works perfectly until I reboot. I guess this is something I need run every time I launch a CS connection unless someone can advise if there's a way to make it stick ... ? At l...
by MOQ888
Mon Apr 03, 2017 9:30 am
Forum: member support & tech assistance
Topic: Ubuntu 16.04 DNS Leaks ...
Replies: 14
Views: 9985

Ubuntu 16.04 DNS Leaks ...

Hey guys, sorry to drag this up but for years I've enjoyed CS - until last night. Seems I have the dreaded DNS Leak despite setting the info in GitHub. Symptom - I get a message saying this website is blocked because it contravenes (Aust) law. What I've done so far - 1. Kept Ubuntu updated 2. Instal...