Killswitch / DeepDNS Problem

Post a reply

Smilies
:D :) ;) :( :o :shock: :? 8-) :lol: :x :P :oops: :cry: :evil: :twisted: :roll: :!: :?: :idea: :arrow: :| :mrgreen: :geek: :ugeek: :angel: :clap: :crazy: :eh: :lolno: :problem: :shh: :shifty: :sick: :silent: :think: :thumbdown: :thumbup: :wave: :wtf: :yawn:

BBCode is ON
[img] is ON
[flash] is OFF
[url] is ON
Smilies are ON

Topic review
   

If you wish to attach one or more files enter the details below.

Maximum filesize per attachment: 130 MiB.

Expand view Topic review: Killswitch / DeepDNS Problem

Re: Killswitch / DeepDNS Problem

by df » Sat Jan 23, 2021 5:09 am

I think the problem was that cryptostorm.nu had no main A record because I deleted it a few days ago (since the box it pointed to was dead). It's since been moved to the main website's server, and I just finished putting the token checker and whatnot on it, so that might fix the widget DNS issue you two were having. The chat thing is back up too - https://cryptostorm.nu/chat

Re: Killswitch / DeepDNS Problem

by Bluemoon » Sat Jan 23, 2021 1:59 am

All good now (DeepDNS and Killswitch) ! :thumbup:

"Bonus" Node list update working too ! :thumbup:

Thank you. :)

Re: Killswitch / DeepDNS Problem

by marzametal » Fri Jan 22, 2021 1:24 pm

Tried that... didn't work. I am stumped!

Re: Killswitch / DeepDNS Problem

by Bluemoon » Thu Jan 21, 2021 4:02 pm

Getting now

Error: Cannot resolve moldova.cstorm.is

So I re-enabled through the GUI

DNSCrypt as well

and all the nodes got resolved

but when getting to

Killswitch - Getting DeepDNS IPs...

got marzametal's original error message

I'm OK to wait until you finish all the other issues, don't get stressed !

Thank you.

Re: Killswitch / DeepDNS Problem

by df » Wed Jan 20, 2021 11:13 pm

Also try disabling the killswitch temporarily by opening the same file and setting killswitch=on to killswitch=off, then re-enable it in the GUI.
There were 4 IPs in public.deepdns.net's DNS that were pointing to dead servers, they're removed now, so if that was the issue just wait a few mins for the DNS to propagate (shouldn't take more than a few minutes, caching aside) then try again

Re: Killswitch / DeepDNS Problem

by Bluemoon » Wed Jan 20, 2021 7:03 pm

Have the same issue.

Can't remember if it started before or after last week Microsoft update (Win 10 Build 19042.746), but it's very recent.

Did changed dnscrypt=on to dnscrypt=off but no go, problem is still there.

Re: Killswitch / DeepDNS Problem

by df » Wed Jan 20, 2021 1:47 pm

That is the latest version. Try closing the widget, then disabling DNSCrypt manually by editing C:\Program Files (x86)\Cryptostorm Client\user\config.ini and changing dnscrypt=on to dnscrypt=off (use a text editor like Notepad++ that'll correctly switch to Administrator mode since you need admin access to edit that file), then restarting the widget.

Re: Killswitch / DeepDNS Problem

by marzametal » Wed Jan 20, 2021 1:40 pm

I tried activating killswitch with the firewall completely disabled. The error still popped up.

The DNS entries are empty prior to running the widget. After I load the widget, the DNS is set to 127.0.0.1

I have also tried manually setting the DNS entries to 1.1.1.1 and 8.8.8.8, but the error still pops up.

Also, would you have a link for the latest version please?

Re: Killswitch / DeepDNS Problem

by df » Wed Jan 20, 2021 9:35 am

My guess is either firewall rules are preventing it, or the DNS is set to something odd. Start -> run -> firewall.cpl -> Advanced settings and check the inbound and outbound rules, remove any cryptostorm ones already there. If it's DNS, start -> run -> ncpa.cpl -> right click on your active network adapter -> properties -> IPv4 -> properties -> Obtain DNS settings automatically (or manually specify something else, like 1.1.1.1 or 8.8.8.8)

EDIT:
That part in the widget resolves public.deepdns.net, which resolves to all of the DeepDNS IPs. Since there's alot of them, it'll switch over to TCP for the response. So if you've got anything block TCP port 53, that'll also break it.

Re: Killswitch / DeepDNS Problem

by marzametal » Sat Jan 16, 2021 5:16 am

I tried a fresh install, just in case I made some dodgy changed to my OS. The error is still present.

Killswitch / DeepDNS Problem

by marzametal » Wed Jan 13, 2021 5:33 am

I've recently ran into an issue when applying the killswitch on the windows widget.

When it comes to getting the DeepDNS IPs, it pops up with an error.
"Error: Cannot resolve. The requested name is valid, but no data of the requested type was found."

https://ibb.co/XDM9055

Any ideas?

Top